IronMQ v3 (AWS US-East) issue
Incident Report for Iron.io
Resolved
Service has been restored to functional status. Due to an issue with connections not closing properly on the hosts in the original public v3 cluster, this required a necessary failover to a new v3 cluster. During this timeframe, some customer queues and messages were lost due to the deteriorated health of the original cluster. Upon failing over to the new MQv3 cluster, most customers were able to see their queues and messages. In the days following service restoration, we have been able to migrate customer messages off of the failed cluster. Unfortunately, some messages have not been retrievable. Development Operations will continue all efforts to migrate all available messages to the new v3 cluster, and expect this laborious procedure will continue over the next few days. All customers whose queues and messages were recoverable have now been moved onto the new cluster. Development Operations is identifying the list of customers whose messages were not recoverable, in order to confirm message status.
Posted Jul 26, 2016 - 14:48 PDT
Monitoring
We have identified the issue and implemented a solution. We expect to post our return to normal status momentarily.
Posted Jul 26, 2016 - 08:11 PDT
This incident affected: IronMQ v3 (AWS US-East).